de Queen Agouti, 1 año han pasado desde su publicación, escrito en Plain Text.
Este código es una respuesta a Sin título de Smelly Gorilla
- ver diferencias
Insertar vínculo
  1. └──┤ yaourt flexget
  2. 1 aur/flexget 1.2.491-2 (64) (0,10)
  3.     Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
  4. 2 aur/flexget-git 2.0.16.r9359.cc99fd6-1 (2) (0,22)
  5.     Automate downloading or processing content (torrents, podcasts, etc.) from different sources like RSS-feeds, html-pages, various sites and more.
  6. ==> Introduzca el número de los paquetes desea instalar (ejemplos: 1 2 3 ó 1-3)
  7. ==> ---------------------------------------------------------------------------
  8. ==> 1
  9.  
  10.  
  11. ==> Descargando PKGBUILD para flexget desde AUR...
  12. x .SRCINFO
  13. x ChangeLog
  14. x PKGBUILD
  15. x fix_beautifulsoup_4_4_0.patch
  16. x flexget.service
  17. cgirard commented on 2016-03-18 09:44                    
  18. OK, sorry about this. I've created python2-flask-restplus086 for Flexget and updated the SRCINFO of python2-flask-restplus.
  19.  
  20. sleduc commented on 2016-03-18 19:54                     
  21. Thanks, I updated the dependency (and the package version), it should all work correctly now.
  22.  
  23. adam900710 commented on 2016-04-28 02:50                         
  24. Any idea to stripe off the so many python dependency?
  25.  
  26. Or is there any option to disable features which I won't need?
  27.  
  28. Personally speaking, I just need flexget to filter torrents and download to given dir.
  29. Nothing more, the dependency makes me quite scared though.
  30.  
  31. sleduc commented on 2016-04-28 17:54                     
  32. Unfortunately I do not think this is possible.
  33. In fact I guess it would require some modification of the code of Flexget to be more "modular".
  34. But I fear we can't do much on the "packaging" side since flexget will not even start if one dependency is missing.
  35. Maybe you could ask this question "upstream" (in https://github.com/Flexget/Flexget/issues)
  36.  
  37. adam900710 commented on 2016-04-29 01:55                         
  38. Thanks, I asked in upstream IRC, and decided to use virtualenv + pip do install it for a given user.
  39.  
  40. flexget 1.2.491-2  (2016-03-18 19:53)
  41. (Paquete sin soporte: ¡podría ser peligroso!)
  42. ==> ¿Quiere editar PKGBUILD? [S/n] ("A" para anular)
  43. ==> ------------------------------------------------
  44. ==> n
  45.  
  46. ==> dependencias de flexget:
  47.  - python2 (ya instalado)
  48.  - python2-feedparser (ya instalado)
  49.  - python2-sqlalchemy (ya instalado)
  50.  - python2-yaml (ya instalado)
  51.  - python2-beautifulsoup4 (ya instalado)
  52.  - python2-html5lib (ya instalado)
  53.  - python2-pyrss2gen (ya instalado)
  54.  - python2-pynzb (ya instalado)
  55.  - python2-progressbar (ya instalado)
  56.  - python2-rpyc (ya instalado)
  57.  - python2-jinja (ya instalado)
  58.  - python2-requests (ya instalado)
  59.  - python2-dateutil (ya instalado)
  60.  - python2-jsonschema (ya instalado)
  61.  - python2-path (ya instalado)
  62.  - python2-apscheduler (ya instalado)
  63.  - python2-pytvmaze>=1.4.5 (ya instalado)
  64.  - python2-ordereddict (ya instalado)
  65.  - python2-cherrypy>=3.7.0 (ya instalado)
  66.  - python2-flask (ya instalado)
  67.  - python2-flask-restful (ya instalado)
  68.  - python2-flask-restplus086 (ya instalado)
  69.  - python2-flask-compress (ya instalado)
  70.  - python2-flask-login>=0.3.2 (ya instalado)
  71.  - python2-flask-cors>=2.1.2 (ya instalado)
  72.  - python2-pyparsing>=2.0.3 (ya instalado)
  73.  - python2-safe (ya instalado)
  74.  - python2-paver (ya instalado) [makedepend]
  75.  - python2-setuptools (ya instalado) [makedepend]
  76.  - python2-guessit>=2.0.3 (compilando desde AUR)
  77.  
  78.  
  79. ==> Continuar compilando flexget? [S/n]
  80. ==> -----------------------------------
  81. ==> s
  82.  
  83. ==> Compilando e instalando el paquete
  84. ==> Instalar o compilar las dependencias que faltan para flexget:
  85.  
  86. ==> Descargando PKGBUILD para python2-guessit desde AUR...
  87. x .SRCINFO
  88. x .gitignore
  89. x PKGBUILD
  90. highway commented on 2016-05-08 15:33                    
  91. err just the older version of dateutil? the current version is 2.5.3
  92.  
  93. kazuo commented on 2016-05-09 00:54                      
  94. @cgirard can you please stop versioning each dep of every package you touch?
  95.  
  96. kazuo commented on 2016-05-09 01:07                      
  97. @cgirard when using versioned deps you need to coordinated releases with the others maitainers, but you can't even coordinate releases with yourself. python2-guessit is at 2.0.5 but flexget-git needs 2.0.4!
  98.  
  99. highway commented on 2016-05-16 21:09                    
  100. how long until we can flag this as out of date? @kazuo @cgirard
  101.  
  102. cgirard commented on 2016-05-17 09:34                    
  103. This package is up to date and the dependencies are aligned with upstream. If you are not happy, bug upstream, not me.
  104.  
  105. python2-guessit 2.0.5-1  (2016-05-06 12:30)
  106. (Paquete sin soporte: ¡podría ser peligroso!)
  107. ==> ¿Quiere editar PKGBUILD? [S/n] ("A" para anular)
  108. ==> ------------------------------------------------
  109. ==> n
  110.  
  111. ==> dependencias de python2-guessit:
  112.  - python2 (ya instalado)
  113.  - python2-rebulk>=0.7.1 (ya instalado)
  114.  - python2-regex (ya instalado)
  115.  - python2-babelfish>=0.5.5 (ya instalado)
  116.  - python2-setuptools (ya instalado) [makedepend]
  117.  - python2-dateutil<2.5.2 (compilando desde AUR)
  118.  
  119.  
  120. ==> Continuar compilando python2-guessit? [S/n]
  121. ==> -------------------------------------------
  122. ==> s
  123.  
  124. ==> Compilando e instalando el paquete
  125. ==> Instalar o compilar las dependencias que faltan para python2-guessit:
  126. [sudo] password for nene:
  127. error: destino no encontrado: python2-dateutil<2.5.2
  128. ==> ¿Reiniciar la compilación de python2-guessit? [s/N]
  129. ==> ---------------------------------------------------
  130. ==> n
  131.  
  132. ==> ¿Reiniciar la compilación de flexget? [s/N]
  133. ==> -------------------------------------------
  134. ==> n
  135.  
  136. ~ }
  137. └──┤
  138.